Instalando Ruby+Rails no Ubuntu 9.04

Ruby On RailsBom, para instalar o ruby é super fácil… é só entrar no terminal e da um sudo apt-get install ruby, assim é instalada a versão mais recente do ruby. Para instalar o rails é só entrar no termnal e digitar sudo gem install rails –include-dependencies. É ai que o problema começa.. Quando tentava fazer uma aplicação com banco de dados mysql ele simplismente fazia duas aplicações…Por exemplo: rails teste -d mysql . Ele simplismente fazia duas aplicações… uma aplicação chamada teste e a outra chamada mysql. Depois ele começou a não aceitar o comando script/server. Começei a procurar a internet e achei um poste bem interessante: Simples Idéias.

Ele simplismente fala que o rubygems não se comporta corretamente no UBUNTU–

Quando você vai instalar um gem — Rails, ZenTest ou outro qualquer — o gerenciador Gems irá baixá-lo e instalá-lo, mas não irá criar os links simbólicos. Então, você não conseguirá rodar os comandos rails ou autotest, por exemplo.

Então com isso vamos entrar no site do rubygems e baixar a versão mais recente. Em seguidade descompacte o arquivo.. Acesse-o pelo teminal e entre com o comando sudo ruby setup.rb. Com isso os problemas que estavam acontecendo com meu rails parou XD

  1. No trackbacks yet.

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: